ProRealTime
Pour discuter sur l’interface de ProRealTime Software, nos configurations graphiques...

Problème ProOrder

par Ice. » 16 juil. 2014 15:46

Bonjour tout le monde !

Petit problème avec ProOrder : les ordres ne passent pas, il ne se passe rien lorsque le système tourne. Pourtant en backtest, le programme marche parfaitement et les ordres qui aurait dû être passé en réel sont bien affichés.

ProOrder est bien activé sur ig, j'ai redémarré plusieurs fois prt, j'ai essayé sur deux instruments et deux programmes.

Est-ce que quelqu'un a le même problème ? :)

(Je suis sur le Forex en mini-lot)

Merci merci !

Re: Problème ProOrder

par Obi Wan Kenobi » 16 juil. 2014 18:25

Je ne pas t'aider je n'utilise pas de logiciel automatique

Re: Problème ProOrder

par Fatah » 16 juil. 2014 19:25

Salut !

justement ce matin, je me disais tiens ig nous donne accès à ProOrder

Je vais regarder ça en détail pour une petite stratégie ;)

Sinon, je n'ai pas de réponse à ta question...

Appelle ig ;)

Re: Problème ProOrder

par Ice. » 16 juil. 2014 19:39

Merci quand même les gars ;) J'ai appellé directement prt mais au final j'ai surement trouvé la solution, j'attend juste un signal pour voir si un ordre s'enclenche, je ne sais pas combien de temps je vais attendre :lol2:

Je repasserai donner la solution si le problème est résolu

Re: Problème ProOrder

par Ice. » 17 juil. 2014 19:30

Ouiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii *Danse de la joie*


Après 2 jours d'acharnement et de multiples invocations vaudou pour faire fonctionner l'engin, j'ai réussi !! :D

Alors, à priori, le système interne à ProOrder prend en mémoire un nombre de Bougie passée très peu élevé contrairement aux graphiques (où on peut régler ce nombre à 200/1000/10 000 etc.... ). Cela signifie que si l'on a des variables qui prennent des données durant un moment bien précis de la semaine ou de la journée (comme par exemple l'open ou autre moment particulier selon les conditions) avec une ut courte, cela ne fonctionne pas !
Un terrible casse-tête, mais j'ai réussi à m'en sortir.

Re: Problème ProOrder

par clodreb » 18 juil. 2014 09:25

Ice. a écrit :Ouiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii *Danse de la joie*


Après 2 jours d'acharnement et de multiples invocations vaudou pour faire fonctionner l'engin, j'ai réussi !! :D

Alors, à priori, le système interne à ProOrder prend en mémoire un nombre de bougie passée très peu élevé contrairement aux graphiques (où on peut régler ce nombre à 200/1000/10 000 etc.... ). Cela signifie que si l'on a des variables qui prennent des données durant un moment bien précis de la semaine ou de la journée (comme par exemple l'open ou autre moment particulier selon les conditions) avec une UT courte, cela ne fonctionne pas !
Un terrible casse-tête, mais j'ai réussi à m'en sortir.
Hello Ice,
je suis en train d'essayer de faire tourner ProOrder et ça ne semble pas fonctionner.
tu avais quel type de message d'erreur ?
perso, je me fais éjecter du système à chaque fois et il me dit que mon ordre a provoqué un arrêt du système de trading (alors qu'en backtest, il n'y a aucun problème).

quand tu dis qu'il ne prend pas beaucoup de bougie en mémoire, tu as un ordre de grandeur ?

Re: Problème ProOrder

par Fredo » 18 juil. 2014 09:42

Je crois que c'est 200 bougies.
Il y a une fonction qui permet de le définir pour les probacktest et qu'il faut mettre en début de codage : Defparam PreloadBars = X où X sera le nombre de barres à affichjer et utiliser dans la stratégie.
Je crois que ça marche aussi dans ProOrder.

Re: Problème ProOrder

par clodreb » 18 juil. 2014 09:59

le preloadbars ne semble pas changer grand chose .....grrrrr, m'énerve ce truc :lol:

Re: Problème ProOrder

par Ice. » 18 juil. 2014 10:26

Salut Clodreb ! Aucun message d'erreur, il ne se passait juste rien du tout.

Je pense que Fredo a raison, cela doit être dans les 200. (800 grand grand max à mon avis)

Rah je n'avais pas pensé au preloadbars mais pas sur que cela fonctionne car cela pourrait surcharger les serveurs si tout le monde utilisait cela.

Fais-tu appelles à des indicateurs externes ? Regarde de ce côté là sinon... ;)

Re: Problème ProOrder

par clodreb » 18 juil. 2014 10:28

j'ai viré tout mon code et j'ai mis la simple commande :

sellshort 2 share AT market

en mettant maximummum 10 contrat et il m'éjecte ....???? là franchement, je ne comprends pas

Sujets similaires
Problème de code et de ProOrder
par julian72 » 15 janv. 2016 21:23 (4 Réponses)
ProOrder : comment connaitre les conditions de SL
par clodreb » 14 août 2014 07:12 (0 Réponses)
Attention avec multiple ProOrder
par clodreb » 14 août 2014 15:03 (2 Réponses)
Gros Bugs PRT ProOrder trading automatique
par JUPITRADER » 19 nov. 2014 22:19 (11 Réponses)
ProOrder fuseaux horaires
par falex » 10 janv. 2015 22:18 (12 Réponses)
ProOrder - Probacktest : même code - comportement différent
par clodreb » 03 mars 2015 23:20 (45 Réponses)
probacktest / proorder
par vschmitt » 14 juin 2015 23:20 (9 Réponses)
Expert advisor to ProOrder
par falex » 05 sept. 2015 20:19 (3 Réponses)
Le trading automatique avec ProOrder
par falex » 16 sept. 2015 20:58 (11 Réponses)